$re = '/<section\b.*?>\K.*(?=<\/section>)/s';
$str = '<section dsds dss >
dsdsds
= 7372732
""
\' \'
< >
<div fdfdf dsdd ="sd"><div fdfdf dsdd ="sd">fdfd</div>fdfd</div>
ds
dsds dsds
ds dsdsds dsdsd
</section>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);