const regex = /\b(?!(\d)\1{3})[13-9]{4}[1346-9][013-9]{5}\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?!(\\d)\\1{3})[13-9]{4}[1346-9][013-9]{5}\\b', 'gm')
const str = `1345678939 all not same; 1st 4 not same, 5th digit not 5, all digits
3333333333 all are same
4444151617 1st 4 are same
3167518888 5th digit = 5
9876877772 contains a 2
9876870773 contains a 0 in last 5 digits
9870677665 contains a 0 in first 5 digits`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}