$re = '/\b(?!(\d)\1{3})[13-9]{4}[1346-9][013-9]{5}\b/m';
$str = '1345678939 all not same; 1st 4 not same, 5th digit not 5, all digits
3333333333 all are same
4444151617 1st 4 are same
3167518888 5th digit = 5
9876877772 contains a 2
9876870773 contains a 0 in last 5 digits
9870677665 contains a 0 in first 5 digits';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);