use strict;
my $str = '1345678939 all not same; 1st 4 not same, 5th digit not 5, all digits
3333333333 all are same
4444151617 1st 4 are same
3167518888 5th digit = 5
9876877772 contains a 2
9876870773 contains a 0 in last 5 digits
9870677665 contains a 0 in first 5 digits';
my $regex = qr/\b(?!(\d)\1{3})[13-9]{4}[1346-9][013-9]{5}\b/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}