$re = '/\d{1,2}-\d{1,2}-\d{4}/';
$str = '1-23-2018';
$subst = "";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;