import re
regex = re.compile(r"\d{1,2}-\d{1,2}-\d{4}")
test_str = "1-23-2018"
subst = ""
result = regex.sub(subst, test_str, count=1)
if result:
print(result)