import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[A-Za-z0-9](?:[A-Za-z0-9.-]{0,78}[A-Za-z0-9_])?$";
final String string = "a12345678901234567890ABC12345abc6789012345-67.890123456789012345678901234567890_\n"
+ "a123456789012345678901234567890123456789012345678901234567890123456789012345678.\n"
+ "_123456789012345678901234567890123456789012345678901234567890123456789012345678_\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}