import re
regex = re.compile(r"^[A-Za-z0-9](?:[A-Za-z0-9.-]{0,78}[A-Za-z0-9_])?$", flags=re.MULTILINE)
test_str = ("a12345678901234567890ABC12345abc6789012345-67.890123456789012345678901234567890_\n"
"a123456789012345678901234567890123456789012345678901234567890123456789012345678.\n"
"_123456789012345678901234567890123456789012345678901234567890123456789012345678_\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")