$re = '/^[A-Za-z0-9](?:[A-Za-z0-9.-]{0,78}[A-Za-z0-9_])?$/m';
$str = 'a12345678901234567890ABC12345abc6789012345-67.890123456789012345678901234567890_
a123456789012345678901234567890123456789012345678901234567890123456789012345678.
_123456789012345678901234567890123456789012345678901234567890123456789012345678_
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);