const regex = /^[A-Za-z0-9](?:[A-Za-z0-9.-]{0,78}[A-Za-z0-9_])?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[A-Za-z0-9](?:[A-Za-z0-9.-]{0,78}[A-Za-z0-9_])?$', 'gm')
const str = `a12345678901234567890ABC12345abc6789012345-67.890123456789012345678901234567890_
a123456789012345678901234567890123456789012345678901234567890123456789012345678.
_123456789012345678901234567890123456789012345678901234567890123456789012345678_
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}