using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([0-1]?\d|2[0-3]):(?:([0-5]?\d))?:(?:([0-5]?\d))?";
string input = @"30.Jul.2019 This the line I want to match 15:04:09";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}