package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([0-1]?\d|2[0-3]):(?:([0-5]?\d))?:(?:([0-5]?\d))?`)
var str = `30.Jul.2019 This the line I want to match 15:04:09`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}