use strict;
my $str = '30.Jul.2019 This the line I want to match 15:04:09';
my $regex = qr/([0-1]?\d|2[0-3]):(?:([0-5]?\d))?:(?:([0-5]?\d))?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}