$re = '/([0-1]?\d|2[0-3]):(?:([0-5]?\d))?:(?:([0-5]?\d))?/m';
$str = '30.Jul.2019 This the line I want to match 15:04:09';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);