#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\+{0,})(\d{0,})([(]{1}\d{1,3}[)]{0,}){0,}(\s?\d+|\+\d{2,3}\s{1}\d+|\d+){1}[\s|-]?\d+([\s|-]?\d+){1,2}(\s){0,}$"
Local $sString = "(123) 456-7890" & @CRLF & _
"(123)456-7890" & @CRLF & _
"123-456-7890" & @CRLF & _
"1234567890" & @CRLF & _
"+31636363634" & @CRLF & _
"+3(123) 123-12-12" & @CRLF & _
"+3(123)123-12-12" & @CRLF & _
"+3(123)1231212" & @CRLF & _
"+3(123) 12312123" & @CRLF & _
"+3(123) 123 12 12" & @CRLF & _
"075-63546725" & @CRLF & _
"+7910 120 54 54 " & @CRLF & _
"910 120 54 54 " & @CRLF & _
"8 999 999 99 99 " & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")