import re
regex = re.compile(r"^(\+{0,})(\d{0,})([(]{1}\d{1,3}[)]{0,}){0,}(\s?\d+|\+\d{2,3}\s{1}\d+|\d+){1}[\s|-]?\d+([\s|-]?\d+){1,2}(\s){0,}$", flags=re.MULTILINE)
test_str = ("(123) 456-7890\n"
"(123)456-7890\n"
"123-456-7890\n"
"1234567890\n"
"+31636363634\n"
"+3(123) 123-12-12\n"
"+3(123)123-12-12\n"
"+3(123)1231212\n"
"+3(123) 12312123\n"
"+3(123) 123 12 12\n"
"075-63546725\n"
"+7910 120 54 54 \n"
"910 120 54 54 \n"
"8 999 999 99 99 \n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")