#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi).*\.(?:jpe?g|png|gif|pdf)(?:\?\S+)?$"
Local $sString = "trial.gen.OO7.jpg" & @CRLF & _
"http://localhost/index.php/profile/stackoverflow/0000000123.911.png?_id=900d" & @CRLF & _
"fast-n-furious.pdf" & @CRLF & _
"trial.gen.OO7.jpg.php" & @CRLF & _
"http://localhost/index.php/profile/stackoverflow/0000000123.911.?_id=84d" & @CRLF & _
"fast-n-furious"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")