package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi).*\.(?:jpe?g|png|gif|pdf)(?:\?\S+)?$`)
var str = `trial.gen.OO7.jpg
http://localhost/index.php/profile/stackoverflow/0000000123.911.png?_id=900d
fast-n-furious.pdf
trial.gen.OO7.jpg.php
http://localhost/index.php/profile/stackoverflow/0000000123.911.?_id=84d
fast-n-furious`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}