const regex = /.*\.(?:jpe?g|png|gif|pdf)(?:\?\S+)?$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*\\.(?:jpe?g|png|gif|pdf)(?:\\?\\S+)?$', 'gmi')
const str = `trial.gen.OO7.jpg
http://localhost/index.php/profile/stackoverflow/0000000123.911.png?_id=900d
fast-n-furious.pdf
trial.gen.OO7.jpg.php
http://localhost/index.php/profile/stackoverflow/0000000123.911.?_id=84d
fast-n-furious`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}