$re = '/.*\.(?:jpe?g|png|gif|pdf)(?:\?\S+)?$/mi';
$str = 'trial.gen.OO7.jpg
http://localhost/index.php/profile/stackoverflow/0000000123.911.png?_id=900d
fast-n-furious.pdf
trial.gen.OO7.jpg.php
http://localhost/index.php/profile/stackoverflow/0000000123.911.?_id=84d
fast-n-furious';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);