#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!.*([._])\1)[^"'<>\n]{10,100}$"
Local $sString = "testing this" & @CRLF & _
"" & @CRLF & _
"testing th_.is._" & @CRLF & _
"" & @CRLF & _
"testing th__.is._" & @CRLF & _
"" & @CRLF & _
"_test._._."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")