import re
regex = re.compile(r"^(?!.*([._])\1)[^\"'<>\n]{10,100}$", flags=re.MULTILINE)
test_str = ("testing this\n\n"
"testing th_.is._\n\n"
"testing th__.is._\n\n"
"_test._._.")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")