$re = '/^(?!.*([._])\1)[^"\'<>\n]{10,100}$/m';
$str = 'testing this
testing th_.is._
testing th__.is._
_test._._.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);