re = /^(?!.*([._])\1)[^"'<>\n]{10,100}$/m
str = 'testing this
testing th_.is._
testing th__.is._
_test._._.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end