const regex = /\bkey="(abcd(?=.*-xyz\b)(?:-[a-z]+){4})"/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bkey="(abcd(?=.*-xyz\\b)(?:-[a-z]+){4})"', 'gm')
const str = `object{one="ab-vwxc",two="value1",key="abcd-eest-wd-xyz-bnn",four="obsolete Values"}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}