$re = '/\bkey="(abcd(?=.*-xyz\b)(?:-[a-z]+){4})"/m';
$str = 'object{one="ab-vwxc",two="value1",key="abcd-eest-wd-xyz-bnn",four="obsolete Values"}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);