#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^my_table_[0-9]+$"
Local $sString = "my_table_123" & @CRLF & _
"my_table_436814" & @CRLF & _
"my_table_35413" & @CRLF & _
"" & @CRLF & _
"my_table_old_14353" & @CRLF & _
"my_table_351434_times"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")