package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^my_table_[0-9]+$`)
var str = `my_table_123
my_table_436814
my_table_35413
my_table_old_14353
my_table_351434_times`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}