using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^my_table_[0-9]+$";
string input = @"my_table_123
my_table_436814
my_table_35413
my_table_old_14353
my_table_351434_times";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}