// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^my_table_[0-9]+$").unwrap();
let string = "my_table_123
my_table_436814
my_table_35413
my_table_old_14353
my_table_351434_times";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}