using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bCOLOR=""[^\na-zA-Z""]*\b([a-zA-Z]+)\b[^\n""]*""";
string input = @"COLOR=""WHITE 화이트"", DETAIL=""NONE""
SLEEVE=""SHORT 쇼트"", COLOR=""BLUE""
SLEEVE=""LONG"", COLOR=""GRAY"", TOP=""DOUBLE""
COLOR=""YELLOW 노랑""
COLOR=""화이트 WHITE"", DETAIL=""NONE""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}