import Foundation
let pattern = #"\bCOLOR="[^\na-zA-Z"]*\b([a-zA-Z]+)\b[^\n"]*""#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
COLOR="WHITE 화이트", DETAIL="NONE"
SLEEVE="SHORT 쇼트", COLOR="BLUE"
SLEEVE="LONG", COLOR="GRAY", TOP="DOUBLE"
COLOR="YELLOW 노랑"
COLOR="화이트 WHITE", DETAIL="NONE"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)