re = /\bCOLOR="[^\na-zA-Z"]*\b([a-zA-Z]+)\b[^\n"]*"/m
str = 'COLOR="WHITE 화이트", DETAIL="NONE"
SLEEVE="SHORT 쇼트", COLOR="BLUE"
SLEEVE="LONG", COLOR="GRAY", TOP="DOUBLE"
COLOR="YELLOW 노랑"
COLOR="화이트 WHITE", DETAIL="NONE"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end