const regex = /A(?!\D*[A-Z]{2})\D*(\d+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('A(?!\\D*[A-Z]{2})\\D*(\\d+)', 'gm')
const str = `A bcd 1 should match
Abcd1 should match
A bcd should not match because there is no number
A bCD 1 should not match because there is capital C between the A and the number
A bcd 1 B should match because \`1\` is before the B
A test this is S 2 test B test 13 A again a test 4
A bcd 1 should match and capture 1
Abcd1 should match and capture 1
A bcd should not match because there is no number
A bcd 1 EF should match because 1 is before the EF
A BCd 1 should not match because there is a capital C between the A and the number`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}