import Foundation
let pattern = #"A(?!\D*[A-Z]{2})\D*(\d+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
A bcd 1 should match
Abcd1 should match
A bcd should not match because there is no number
A bCD 1 should not match because there is capital C between the A and the number
A bcd 1 B should match because `1` is before the B
A test this is S 2 test B test 13 A again a test 4
A bcd 1 should match and capture 1
Abcd1 should match and capture 1
A bcd should not match because there is no number
A bcd 1 EF should match because 1 is before the EF
A BCd 1 should not match because there is a capital C between the A and the number
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)