$re = '/A(?!\D*[A-Z]{2})\D*(\d+)/m';
$str = 'A bcd 1 should match
Abcd1 should match
A bcd should not match because there is no number
A bCD 1 should not match because there is capital C between the A and the number
A bcd 1 B should match because `1` is before the B
A test this is S 2 test B test 13 A again a test 4
A bcd 1 should match and capture 1
Abcd1 should match and capture 1
A bcd should not match because there is no number
A bcd 1 EF should match because 1 is before the EF
A BCd 1 should not match because there is a capital C between the A and the number';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);