use strict;
my $str = 'A bcd 1 should match
Abcd1 should match
A bcd should not match because there is no number
A bCD 1 should not match because there is capital C between the A and the number
A bcd 1 B should match because `1` is before the B
A test this is S 2 test B test 13 A again a test 4
A bcd 1 should match and capture 1
Abcd1 should match and capture 1
A bcd should not match because there is no number
A bcd 1 EF should match because 1 is before the EF
A BCd 1 should not match because there is a capital C between the A and the number';
my $regex = qr/A(?!\D*[A-Z]{2})\D*(\d+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}