#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)logtype::SAT.*id::(ABC-1|ABC-2).*username::[^\-]+\-(?!TEST)"
Local $sString = "logtype::SAT id::ABC-1 username::fddsd-TEST" & @CRLF & _
"logtype::SAT id::ABC-1 username::fddsd-dsfds"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")