$re = '/logtype::SAT.*id::(ABC-1|ABC-2).*username::[^\-]+\-(?!TEST)/m';
$str = 'logtype::SAT id::ABC-1 username::fddsd-TEST
logtype::SAT id::ABC-1 username::fddsd-dsfds';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);