import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "logtype::SAT.*id::(ABC-1|ABC-2).*username::[^\\-]+\\-(?!TEST)";
final String string = "logtype::SAT id::ABC-1 username::fddsd-TEST\n"
+ "logtype::SAT id::ABC-1 username::fddsd-dsfds";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}