re = /logtype::SAT.*id::(ABC-1|ABC-2).*username::[^\-]+\-(?!TEST)/m
str = 'logtype::SAT id::ABC-1 username::fddsd-TEST
logtype::SAT id::ABC-1 username::fddsd-dsfds'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end