import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:(['\"])(?>\\\\\\1|(?!\\1)[\\w\\W])*\\1|\\/\\*[\\w\\W]*?\\*\\/)(*SKIP)(*F)|\\h*\\/\\/.*+";
final String string = "\"Testing a comment here // comment\" // comment\n\n"
+ "// comment\n\n"
+ "\"A bit \\\" trickier yet \\\" // comment\" // comment\n\n"
+ "// comment\n\n"
+ "// \"This should match since the comment came first\"\n\n"
+ "'Single \\' quotes // comment' // comment\n\n"
+ "'''\n"
+ "Ignore\n"
+ "// comment\n"
+ "\\''''\n\n"
+ "// comment\n\n"
+ "/*\n"
+ "multiline\n"
+ "// comment\n"
+ "*/";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}