import Foundation
let pattern = #"(?:(['"])(?>\\\1|(?!\1)[\w\W])*\1|\/\*[\w\W]*?\*\/)(*SKIP)(*F)|\h*\/\/.*+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
"Testing a comment here // comment" // comment
// comment
"A bit \" trickier yet \" // comment" // comment
// comment
// "This should match since the comment came first"
'Single \' quotes // comment' // comment
'''
Ignore
// comment
\''''
// comment
/*
multiline
// comment
*/
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)