const regex = /(?:(['"])(?>\\\1|(?!\1)[\w\W])*\1|\/\*[\w\W]*?\*\/)(*SKIP)(*F)|\h*\/\/.*+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:([\'"])(?>\\\\\\1|(?!\\1)[\\w\\W])*\\1|\\\/\\*[\\w\\W]*?\\*\\\/)(*SKIP)(*F)|\\h*\\\/\\\/.*+', 'g')
const str = `"Testing a comment here // comment" // comment
// comment
"A bit \\" trickier yet \\" // comment" // comment
// comment
// "This should match since the comment came first"
'Single \\' quotes // comment' // comment
'''
Ignore
// comment
\\''''
// comment
/*
multiline
// comment
*/`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);