import re
regex = re.compile(r"^\S+\h+(\S+)\R\K(?:\S+\h+\1(?:\R|\Z))+", flags=re.MULTILINE)
test_str = ("lineA 12345\n"
"lineB 12345\n"
"lineC 12345\n"
"lineD 788878\n"
"lineE 110881\n"
"lineF 110881\n"
"lineG 110881\n"
"lineH 287778\n"
"lineJ 251287\n"
"lineK 242424\n"
"lineL 242424\n"
"lineM 242424")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)