re = /^\S+\h+(\S+)\R\K(?:\S+\h+\1(?:\R|\Z))+/m
str = 'lineA 12345
lineB 12345
lineC 12345
lineD 788878
lineE 110881
lineF 110881
lineG 110881
lineH 287778
lineJ 251287
lineK 242424
lineL 242424
lineM 242424'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result