import Foundation
let pattern = #"^\S+\h+(\S+)\R\K(?:\S+\h+\1(?:\R|\Z))+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
lineA 12345
lineB 12345
lineC 12345
lineD 788878
lineE 110881
lineF 110881
lineG 110881
lineH 287778
lineJ 251287
lineK 242424
lineL 242424
lineM 242424
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)