import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bp(ost|ostal)?(([ \\.]*(O|0|o)(ffice)?)|([ \\.]*box))([ \\.]*Box)?\\b";
final String string = "po box 1272\n"
+ "po box 29407\n"
+ "3001 p street suite a\n"
+ "po box 882\n"
+ "490 post st ste 700\n"
+ "530 post cpurt\n"
+ "530 post ct\n"
+ "postal box 1216\n"
+ "2 mile klondike highway po box 440\n"
+ "mile 1.5 klondike hwy po box 535\n"
+ "346 a tundra way po box 324\n"
+ "7307 s frontier drive/po box 877509\n"
+ "4540 edinburgh dr. po box 545, king salmon\n"
+ "650 oliver rd. po box 241702\n"
+ "#320 fortaleza street, po box 9024070,\n"
+ "10 el campo\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}