// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)\bp(ost|ostal)?(([ \.]*(O|0|o)(ffice)?)|([ \.]*box))([ \.]*Box)?\b").unwrap();
let string = "po box 1272
po box 29407
3001 p street suite a
po box 882
490 post st ste 700
530 post cpurt
530 post ct
postal box 1216
2 mile klondike highway po box 440
mile 1.5 klondike hwy po box 535
346 a tundra way po box 324
7307 s frontier drive/po box 877509
4540 edinburgh dr. po box 545, king salmon
650 oliver rd. po box 241702
#320 fortaleza street, po box 9024070,
10 el campo
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}