import Foundation
let pattern = #"\bp(ost|ostal)?(([ \.]*(O|0|o)(ffice)?)|([ \.]*box))([ \.]*Box)?\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = ##"""
po box 1272
po box 29407
3001 p street suite a
po box 882
490 post st ste 700
530 post cpurt
530 post ct
postal box 1216
2 mile klondike highway po box 440
mile 1.5 klondike hwy po box 535
346 a tundra way po box 324
7307 s frontier drive/po box 877509
4540 edinburgh dr. po box 545, king salmon
650 oliver rd. po box 241702
#320 fortaleza street, po box 9024070,
10 el campo
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)